On Tuesday, 9 March 2021 5:58:12 AM AEDT Ralph Campbell wrote:
On 3/3/21 10:16 PM, Alistair Popple wrote:
Migration is currently implemented as a mode of operation for try_to_unmap_one() generally specified by passing the TTU_MIGRATION flag or in the case of splitting a huge anonymous page TTU_SPLIT_FREEZE.
However it does not have much in common with the rest of the unmap functionality of try_to_unmap_one() and thus splitting it into a separate function reduces the complexity of try_to_unmap_one() making it more readable.
Several simplifications can also be made in try_to_migrate_one() based on the following observations:
- All users of TTU_MIGRATION also set TTU_IGNORE_MLOCK.
- No users of TTU_MIGRATION ever set TTU_IGNORE_HWPOISON.
- No users of TTU_MIGRATION ever set TTU_BATCH_FLUSH.
TTU_SPLIT_FREEZE is a special case of migration used when splitting an anonymous page. This is most easily dealt with by calling the correct function from unmap_page() in mm/huge_memory.c - either try_to_migrate() for PageAnon or try_to_unmap().
Signed-off-by: Alistair Popple apopple@nvidia.com Reviewed-by: Christoph Hellwig hch@lst.de
Looks reasonable to me. I do worry a bit about code duplication.
I was initially concerned about this when splitting try_to_unmap_one() up but most of the code paths ended up being pretty orthogonal and I think the clarity gained from separating them is worth a small amount of duplication.
At some point in the future, it might be discovered that other combinations of TTU_XXX flags are needed in which case a careful check of
try_to_migrate()
and try_to_unmap() will be needed.
I wanted to keep the code as simple as possible by removing all dead code paths that that weren't in use today.
I think this is likely to be more of an issue if new TTU_XXX flags are added as there are already explicit (and hopefully exhaustive) checks in try_to_migrate() and try_to_unmap() for unsupported combinations of existing flags. To avoid ending up in the same situation again I would rather not have more TTU_XXX flags added if at all possible though.
Reviewed-by: Ralph Campbell rcampbell@nvidia.com
Thanks.
- Alistair