"Failed to start message bus" problem

Nikola Pizurica pizurica at neobee.net
Thu Nov 4 02:53:35 PST 2004

I've noticed that automounting of my usb disk and cd rom stopped working
on Ubuntu. It worked till few days ago, and I don't remeber doing
anything drastic to my system.
During boot, I've noticed this error:
Failed to start message bus: Failed to bind socket
"/var/run/dbus/system_bus_soc ket": Address already in use

I've tried to run Computer-Desktop Preferences-Removable Storage but got
this error:

The "hald" service is required but not currently running. Enable the
service and rerun this applet, or contact your system administrator.

So, I tried vith lshal and got this error:

ubuntu:~# lshal
lshal version 0.4.0
libhal.c 644 : Error connecting to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: Input/output error
error: hal_initialize failed

So, I've tried updating hal and got this:

Setting up hal (0.4.0-1ubuntu2) ...
Installing new version of config file /etc/hal/hald.conf ...
 Removing any system startup links for /etc/init.d/hal ...
 * Restarting system message bus...
 * Stopping Hardware Abstraction Layer...                                [ ok ]
Failed to start message bus: Failed to bind socket "/var/run/dbus/system_bus_socket": Address already in use
invoke-rc.d: initscript dbus-1, action "restart" failed.
dpkg: error processing hal (--configure):

So, what is the problem with starting dbus? How to solve this problem with system_bus_socket?



More information about the dbus mailing list