The patch for the specs

David Zeuthen david at
Wed Dec 8 18:14:16 PST 2004

On Tue, 2004-12-07 at 21:27 +0000, Sergey Udaltsov wrote:
> Hi David

Hi Sergey,

sorry for the lag,

> While I'm waiting for ability to commit the stuff into hal CVS (I am
> still not a member of the hal group), here is the patch for the
> documentation. There are 2 minor changes from the discussed
> properties: I introduced battery.charge_level.* properties (for
> .current, .maximim.real and .maximum.specified) - and split maximum
> charge (making .real optional). All the rest is basically the way we
> discussed it.
> Could you please review and commit.

Minor nitpicks only :-)

> +    <sect2 id="device-properties-battery">
> +      <title><literal>battery</literal> namespace</title>
> +      <para>
> +      
> +       Device objects with the capability <literal>battery</literal>
> +       represent all the devices having some battery (in many cases -
> rechargeable) inside. 

Looks good.

> +       If the device have several batteries inside, it should provide
> +       <literal>battery_object</literal> capability and contain
> several
> +       <literal>battery_unit</literal> subnodes (each of them
> providing
> +       <literal>battery</literal> capability.

I've left this out; if we someday encounter one of these we should deal
with it - I guess this wont happen anytime sson as hal device objects
are meant to represent the the smallest functional units of hardware; if
it is that e.g. a USB device contains several batteries I think we may
be better off just representing it as one battery either way. Laptop
batteries (ACPI, PMU etc.) will have their own device objects if there
is more than one battery.

> +             <entry><literal>PDA</literal></entry>

Renamed this to 'pda'

> +             <entry><literal>UPS</literal></entry>

Renamed to 'ups'

> +             <entry><literal>car</literal></entry>

Left this out - we may add it if someone writes software using hal that
integrates with cars :-)

> +             <entry><literal>cell_phone</literal></entry>

Removed - may add it later.

> +             <entry><literal>laptop</literal></entry>

Renamed to primary with the comment "The battery is a primary power
source for the system - an example are laptop batteries."

> +             <entry><literal>photo_camera</literal></entry>

Renamed to 'camera' since we already use 'camera' exclusively for
digital still cameras.

> +             <entry><literal>unknown</literal></entry>

Renamed to unknown.

> +             <entry><literal>toy</literal></entry>

Left this out :-)

> +             <entry><literal>video_camera</literal></entry>

Left this out - may add it later.

> <entry><literal>battery.rechargeable.time_to_charge</literal>
> (int)</entry>
> +              <entry></entry>
> +              <entry>No</entry>
> +              <entry>The time (measured in minutes) necessary for
> the 

Changed to seconds.

> +              <entry><literal>battery.time_to_discharge</literal>
> (int)</entry>
> +              <entry></entry>
> +              <entry>No</entry>
> +              <entry>The expected worktime of the device  (measured
> in 
> +                minutes), without recharging, from the current moment

Changed to seconds.

I've also added battery.vendor, battery.model and battery.serial as
optional properties.

The patch I committed is this one

Sorry again for the lag - way too many meetings this week :-/


hal mailing list
hal at

More information about the Hal mailing list