[Uim] Renaming plan under uim/ again
tkng at xem.jp
Sat Sep 24 11:49:08 PDT 2005
I'm planning to rename some filenames, add a new file, change the role
of some files. Following list is my plan for now. But since now I don't
have enough time to write code, I'll start working from Oct 1.
uim.c: Context related interface functions.
uim-key: Key event related functions. But uim_press/release_key
should be moved into uim.c.
uim-preedit.c (new): Preedit related code. Maybe it's needless.
uim-plugin.c : Rename from plugin.c.
uim-func.c: Scheme functions. All of functions registered in
uim_init_util_subrs should be moved to here.
uim-iconv.c (new) : Iconv related code.
uim-util.c: Utility functions. These functions should not be exported.
In addition, this file should not include uim-scm.h. Maybe
we should rename this file as uim-misc.c.
uim-ipc.c: Utility functions for inter process communication.
uim-helper*.c: Nothing will be changed.
I want to rename plugin.h as uim-plugin.h, but this will break API.
Since some external plugins already exist, this problem should be
avoided. Copying plugin.h to uim-plugin.h would work.
Any opinions are welcome.
tkng at xem jp
More information about the uim