[Xorg] testing xorg on suse 9.1

Kevin E Martin kem at freedesktop.org
Wed Aug 25 22:28:34 PDT 2004

On Wed, Aug 25, 2004 at 10:46:23PM -0600, Ray Lehtiniemi wrote:
> hi
> i'd be interested in testing the latest xorg servers on my
> home machine.  i run suse 9.1 (free ftp edition) in IA-32.
> i built XORG-6_7_99_902 last night and ran xreg, and got quite
> a few Err files with the xvfb server.
> is there some documentation somewhere about how to use files like
> xtest.15bpp.20040825.000126.results/tset/CH06/drwarc/Err0077.err and
> xtest.15bpp.20040825.000126.results/tset/CH06/drwtxt/Err0307.err?

There is a program that comes with the test suite called "blowup" that
will allow you to view these files.  This is documented in the user
guide found here: xtest/xsuite/xtest/doc/userguide.mm

I'm seeing quite a few failures in XDrawText and XDrawText16 as well as
a few other individual test failures.  I'm investigating each of these
and would be interested to see which tests are failing for you.  Could
you post your summary file so that I could see which tests are failing
on your system?

Also, the XDrawArc and XDrawArcs failures are known and expected.

> i had problems with the xorg server.  although i built with a
> projroot=/tmp/XorgTEST, i got this:
>   # ./xreg -projroot /tmp/XorgTEST  -xtest -xorg
> * Wed Aug 25 14:19:21 MDT 2004: Starting script
> * Wed Aug 25 14:19:21 MDT 2004: XSERVER=/tmp/XorgTEST/bin/Xorg
> * Wed Aug 25 14:19:21 MDT 2004: HOST=ray
> * Wed Aug 25 14:19:21 MDT 2004: DEPTHS=8 15 16 24+32
> * Wed Aug 25 14:19:21 MDT 2004: Getting parameters from X server
> * Wed Aug 25 14:19:21 MDT 2004: Starting X: parameters
> * Wed Aug 25 14:19:21 MDT 2004: Start X server with :1 -depth 24 -fbbpp 32
> * Wed Aug 25 14:19:31 MDT 2004: /tmp/XorgTEST/bin/Xorg failed to start
> the output file showed
>   Fatal server error:
>   Cannot open log file "/var/log/Xorg.1.log"
> so it seems that xorg is not correctly understanding that the
> projroot was set in the host.def file?

It tried to start the Xorg server from your project root, but from the
error, it looks like /tmp/XorgTEST/bin/Xorg is either not owned by root
or not setuid root.  Perhaps you installed everything as yourself
instead of root?  What I normally do is to run the make install as
myself, and then run "chown -R 0.0 /tmp/XorgTEST" as root after the
install completes.

Hope this helps,

More information about the xorg mailing list