DRI R300 corrupted display purely DRI issue ? G5 AGP support
Benjamin Herrenschmidt
benh at kernel.crashing.org
Sun Dec 26 02:02:59 PST 2004
> include/linux/pci_ids.h
> #define PCI_DEVICE_ID_APPLE_UNI_N_AGP8 0x0059
> Maybe i better use :
> #define PCI_DEVICE_ID_APPLE_UNI_N_AGP3 0x0059
> as it seems that this is an AGP3 controller.
Call it PCI_DEVICE_ID_APPLE_U3_AGP
> I need to add this to include/asm/uninorth.h this seems to
> be only used by AGP3 uninorth G5 controller. This values
> came from darwin, their names too. I am only using PERFRD
> at the moment but others maybe usefull latter if we had features
> like fastwrite.
>
> #define UNI_N_CFG_GART_SYNCMODE 0x00040000
> #define UNI_N_CFG_GART_PERFRD 0x00080000
> #define UNI_N_CFG_GART_B2BGNT 0x00200000
> #define UNI_N_CFG_GART_FASTDDR 0x00400000
>
> I use a magic value (not so magic thought :)) 12 which correspond
> to PAGE_SHIFT in darwin this value depend on page size. Is there
> any equivalent infos in linux ? For the moment i use a hardcoded value.
PAGE_SHIFT for now should be fine. If we change the CPU page size, I'll
have to fix the driver anyway.
> I changed uninorth_tbl_flush, uninorth_cleanup,
> uninorth_insert_memory, uninorth_agp_enable
>
> So, i am wondering if it's not better to have a different driver
> like uninorth3 (for AGP3) instead of having test to see if we have
> a G5 agp or an older one in each functions. Moreover maybe more
> of the generic version of agp3(drivers/char/agp/generic.c) could be used.
If they end up to be different enough, yes, make a u3-agp driver
separate. I don't think much of the generic stuff can be used.
> Any comment on this would be appreciated.
>
> best,
> Jerome Glisse
> _______________________________________________
> Linuxppc64-dev mailing list
> Linuxppc64-dev at ozlabs.org
> https://ozlabs.org/cgi-bin/mailman/listinfo/linuxppc64-dev
--
Benjamin Herrenschmidt <benh at kernel.crashing.org>
More information about the xorg
mailing list