[compiz] [ANNOUNCE] compiz-0.7.4

Dennis Kasprzyk onestone at opencompositing.org
Thu Apr 3 08:23:13 PDT 2008

A new compiz release 0.7.4 is now available from:


    which can be verified with:

        a204d9b70ac8abfb037ca3402452aa055f4aab71  compiz-0.7.4.tar.gz

        (signed by Dennis Kasprzyk)

  Additionally, a git clone of the source tree:

        git clone git://git.freedesktop.org/git/xorg/app/compiz

    will include a signed compiz-0.7.4 tag which points to a commit named:

    which can be verified with:
        git verify-tag compiz-0.7.4

    and can be checked out with a command such as:
        git checkout -b build compiz-0.7.4


Configurable handling of overlapping output devices.

Enhanced focus stealing prevention with configurable amount of focus
stealing prevention.

Added configurable, optional delay for edge actions to prevent
accidential invocation.

Generalized vertex system to improve plugin compatibility.

Optimized gaussian blur shaders to support more hardware.

Improved unredirection of fullscreen windows.

Several bugfixes.

Translation updates.


Changes since compiz-0.7.2:

C-F Language team (2):
      compiz translation updates
      translation updates

Danny Baumann (44):
      Annotate draw is a dbus only action, reflect that in the metadata.
      Generalize session event functions to have only one event function 
instead of four.
      Add a sessionInit and a sessionFini callback function.
      Bump ABIVERSION.
      Minor coding style fix.
      Make outputDeviceForGeometry behave smarter when dealing with 
overlapping outputs.
      Clamp point/geometry to compare to visible screen area.
      Reduce duplicated code by reusing the outputDeviceForGeometry function 
to implement outputDeviceForPoint. For this, treat a point x,y just as a 1x1 
sized rectangle which has its upper left corner at x,y.
      Add another overlapping output handling mode "Smart". "Smart" basically 
is the old "Prefer larger" mode, selecting the output most part of the 
rectangle is on. "Prefer larger" and "Prefer smaller" only look for the 
rectangle center to determine the output.
      Remove sessionInit and sessionFini wrappable functions.
      Selected selected window when terminating scale instead of the last 
active window.
      When a position match is given for a window, constrain the positiong to 
the output for the geometry given in the match instead of the current output.
      Make activateWindow function wrappable so plugins can react on window 
      Switch viewports on window activation, not on focus change.
      The largedesktop plugins are responsible for switching viewports when a 
window is activated.
      Add option for selecting the amount of focus stealing prevention.
      Added screen edge trigger delay settings.
      Also use screen edge delays for DnD actions.
      Add nodelay hint to flip edges.
      Bump ABIVERSION.
      Also set w->managed on MapNotify event.
      Improve comment and variable name.
      Use passed geometry for constraining min/max size rather than server 
      Don't send sync requests from reconfigureXWindow function.
      Adjust ConfigureRequest geometry for decoration size. Reference: 
      Send sync request when changing window size due to updating window 
      Don't send out sync request when nothing changed.
      Don't set mask in addWindowSizeChanges if the new geometry matches the 
old geometry.
      Update saved window geometry when adding/removing decorations.
      Recalculate window type before updating window state.
      Always recalculate window type and actions when changing window state.
      Don't allow minimization of windows that don't have the minimize action 
set and reduce code duplication.
      Remove all clones on unload.
      Fix a number of damage issues.
      Correctly unwrap on unload.
      If we couldn't get the timestamp for the window, try to get at least the 
timestamp of its transient parent for determining if the window should get 
focus or not.
      Allow minimization for all normal type windows.
      Recalculate window actions on frame size and transient status changes as 
the available actions depend on both.
      Also maximize too-big-for-workarea windows if their placement was 
      Avoid unnecessarily unloading plugins if the new plugin list does not 
contain the core plugin.
      Allow shading for all kinds of decorated windows.
      Allow key and button bindings being used interchangably in move and 
resize plugins.
      Remove some dead code.
      Update German translation.

Dennis Kasprzyk (26):
      Post release version increment.
      Added an option to control the selection of an output device, if the 
output regions overlap in the given point (xrandr 1.2 clone mode).
      Initialize output size correctly.
      Unredirect top most fullscreen window also if it only covers one output 
device. This also fixes unredirecting of applications/games that change the 
display resolution.
      Set and use w->texCoordSize;
      Added vertexStride window variable.
      Use also "z" component in the vertex array, to ensure that plugins like 
blur that use the vertex array for calculations, can always work with all 
      Use core changes in wobbly.
      Apply core changes to blur.
      Use minimum and maximum "z" component for vertex projection.
      Try to start decorator in initScreen because a value for 
DECOR_DISPLAY_OPTION_COMMAND might been already set in the xml metadata.
      Enable "Drag and Drop" action state for rotate flip edges.
      Calculate a generic rotation progress value and use it to calculate the 
cube zoom out.
      Pass cube progress in getRotation function.
      Use cube progress to calculate cube transparency.
      Moved multi output handling from rotate to cube to make it also work 
with inactive transparency.
      Bump cube ABI.
      Provide glMultiTexCoord2f in screen struct.
      Make as many as possible texture fetches independent in first pass of 
gaussian blur.
      Make as many as possible texture fetches independent in second pass of 
gaussian blur.
      Use constants in the shader code instead of program parameters.
      Added option for the independent texture fetch feature in blur.
      Reorder blur texture fetches, to fetch all pixels in one indirection 
step on radeon cards.
      Bump core ABI.
      Add NEWS entry and bump version for 0.7.4 release.

Erkin Bahceci (1):
      Texture compression for image textures.

Jigish Gohil (1):
      remove wrong be translation

More information about the compiz mailing list