[gst-devel] changes for 0.6.1

Wim Taymans wim.taymans at chello.be
Sun Mar 30 14:50:05 CEST 2003


Hi,

I did a diff -r HEAD in the gstreamer/gst/ directory of
BRANCH-GSTREAMER-0_6. This is an overview of the changes:

API/ABI compatible
------------------

 - DISABLE various core components to reduce lib size for embedded
   systems.
 - fix compilation when DEBUG is disabled (*)
 - gstregistrypool.[ch] added, functions moved out of gstregistry.[ch]
   this makes it possible to disable registry handling for embedded 
   devices.
 - various refcounting fixes (*)
 - refcounting on padtemplates fixed. (*)
 - new element: gstshaper (*)
 - xmlregistry updates (*)
 - gthread based cothread wrapper (*)
 - tons of optimal scheduler fixes (*)
   - refcounting
   - flags
   - flush event

API change (addition)
---------------------

 - gst_bin_remove_many added
 - element locked state flag + gstbin 2 line patch.
 - default scheduler name as a #define in gstscheduler.h

ABI change
----------

 - gstextratypes.[ch] removed, functionality to specify a URI as an
   element property moved to gsturi.h
 - gst_object_swap renamed to gst_object_replace
 - probe perform and dispacth function signature change
 - removed stupid helper function in gstutils that provided a nice 
   API around old gtk1.2 but are not nessesary for glib2
 - gsttrace expanded to support live buffer/event/caps... 
   tracing, duplicated code removed from various subsystems. 
   (ABI change because _print_stats was removed)
 - props_get_type -> props_get_entry_type, props_get_type returns
   a GType for the props struct.


I propose to include all API additions and the changes marked with (*).
The refactoring changes along with the #defines to reduce code size
are quite extensive, speak up ASAP if you want those (or other) changes
in 0.6.1.

The number of ABI changes are still quite low and in some obscure areas
(with the exception of props_get_type) meaning that 0.7.0 (or whenever
we're allowed to break the ABI slightly) could be made from HEAD.

Wim


-- 
Wim Taymans <wim.taymans at chello.be>






More information about the gstreamer-devel mailing list