ee21rh at surrey.ac.uk
Tue Feb 1 04:40:39 PST 2005
Sergey Udaltsov <sergey.udaltsov <at> gmail.com> writes:
> Actually, I was wondering myself - what was the point to make
> system.battery? I don't particularly mind this change - but there
> should be some rationale, shouldn't it?
Good point. "system.*" was originally chosen because it denoted a system device,
and I had always stuck with it. I could argue more to your point, saying why do
we have system.ac_adaptor, rather than just ac_adaptor and system.processor
rather than procesor. I just wanted to signify that they all come from the same
class of objects, feel free to send a patch to remove the system.* bit. I think
it makes sense to have the object on it's own, without a system.* prefix.
hal mailing list
hal at lists.freedesktop.org
More information about the Hal