Mesa (master): nir/glsl: Use shader_prog->Name for naming the NIR shader

Jason Ekstrand jekstrand at kemper.freedesktop.org
Thu Oct 15 14:36:01 UTC 2015


Module: Mesa
Branch: master
Commit: b705005584730cff75f5bbe057832d8b1106124a
URL:    http://cgit.freedesktop.org/mesa/mesa/commit/?id=b705005584730cff75f5bbe057832d8b1106124a

Author: Jason Ekstrand <jason.ekstrand at intel.com>
Date:   Thu Oct  8 18:36:27 2015 -0700

nir/glsl: Use shader_prog->Name for naming the NIR shader

This has the better name to use. Aparently, sh->Name is usually 0.

Reviewed-by: Kenneth Graunke <kenneth at whitecape.org>
Reviewed-by: Neil Roberts <neil at linux.intel.com>

---

 src/glsl/nir/glsl_to_nir.cpp |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/glsl/nir/glsl_to_nir.cpp b/src/glsl/nir/glsl_to_nir.cpp
index 0e4289b..5aba8f8 100644
--- a/src/glsl/nir/glsl_to_nir.cpp
+++ b/src/glsl/nir/glsl_to_nir.cpp
@@ -150,7 +150,7 @@ glsl_to_nir(const struct gl_shader_program *shader_prog,
       if (sh->Program->SamplersUsed & (1 << i))
          num_textures = i;
 
-   shader->info.name = ralloc_asprintf(shader, "GLSL%d", sh->Name);
+   shader->info.name = ralloc_asprintf(shader, "GLSL%d", shader_prog->Name);
    shader->info.num_textures = num_textures;
    shader->info.num_ubos = sh->NumBufferInterfaceBlocks;
    shader->info.num_abos = shader_prog->NumAtomicBuffers;




More information about the mesa-commit mailing list