[Mesa-dev] [Bug 36182] Game Trine from http://www.humblebundle.com/ needs ATI_draw_buffers

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Wed Apr 13 03:00:44 PDT 2011


--- Comment #9 from Marek Olšák <maraeo at gmail.com> 2011-04-13 03:00:43 PDT ---
(In reply to comment #8)
> (In reply to comment #7)
> > No, it doesn't. First, there is no Shader Model 3 in OpenGL per se. Second,
> > ARB_fragment_program matches DX9's Shader Model 2, not 3, so the game lies
> > about it.
> OpenGL does not allow for reliable detection of Shader Model 3 but it IS
> required because some of the shaders are too complex for Shader Model 2
> hardware.

I don't see any shaders in that log that would need SM3.0. Yes, there is one
with 454 instructions, but that's still well within the limits of SM2.0b.

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the mesa-dev mailing list