[Mesa-dev] [PATCH 1/2] glsl: Rename class variable_entry to ir_variable_refcount_entry.
eric at anholt.net
Mon Jan 30 08:25:34 PST 2012
On Sat, 28 Jan 2012 16:58:37 -0800, Kenneth Graunke <kenneth at whitecape.org> wrote:
> Exporting a publicly visible class with a generic name like
> "variable_entry" via ir_variable_refcount.h is kind of mean.
> Many IR transformers would like to define their own "variable_entry"
> class. If they accidentally include this header, the compiler/linker
> may get confused and try to instantiate the wrong variable_entry class,
> leading to bizarre runtime crashes.
> The hope is that renaming this one will allow .cpp files to safely
> declare and use their own file-scope "variable_entry" classes.
> This avoids crashes caused by converting src/glsl to automake.
> Signed-off-by: Kenneth Graunke <kenneth at whitecape.org>
> Reviewed-and-tested-by: Matt Turner <mattst88 at gmail.com>
Reviewed-by: Eric Anholt <eric at anholt.net>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 197 bytes
Desc: not available
More information about the mesa-dev