[Mesa-dev] Four questions about DRI1 drivers

Connor Behan connor.behan at gmail.com
Thu Mar 1 11:25:41 PST 2012

On 01/03/12 01:36 AM, Dave Airlie wrote:
> You can still build r128_dri.so from Mesa 7.11 and it will work with 
> later Mesa libGLs fine. You just can't build it from Mesa 8.0 source 
> anymore. 
Really? Even if no one updates r128 to stay compatible with new libGLs 
and no one updating libGL gives a second thought as to whether that 
update will break r128? I thought the whole point of removing DRI1 
drivers is that most of you are too pressured to keep that promise. If 
the plan really is to update libGL carefully so that DRI1 drivers will 
always work with it, then it seems like their removal does nothing but 
save a few MB of space on the git server.

More information about the mesa-dev mailing list