[Mesa-dev] [PATCH 04/23] glsl: Add image memory and layout qualifiers to ir_variable.

Paul Berry stereotype441 at gmail.com
Wed Dec 11 13:21:37 PST 2013


On 26 November 2013 00:02, Francisco Jerez <currojerez at riseup.net> wrote:

>
> +    * ARB_shader_image_load_store qualifiers.
> +    */
> +   struct {
> +      bool read_only;
> +      bool write_only;
>

It's hard to come up with a good naming convention for read_only and
write_only--should they have underscores (like the GLenum values
GL_READ_ONLY and GL_WRITE_ONLY) or not (like the GLSL keywords readonly and
writeonly)?  I think you've made a reasonable choice to standardize on
always using underscores.  However, I would appreciate a short comment next
to "read_only" and "write_only" to indicate that the corresponding GLSL
keywords are "readonly" and "writeonly".

With that change, the patch is:

Reviewed-by: Paul Berry <stereotype441 at gmail.com>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/mesa-dev/attachments/20131211/8357fda3/attachment.html>


More information about the mesa-dev mailing list