[Mesa-dev] [PATCH 1/7] mesa: Clean up nomenclature for pipeline stages.

Kenneth Graunke kenneth at whitecape.org
Tue Jan 7 15:08:21 PST 2014


On 01/07/2014 02:13 PM, Paul Berry wrote:
> Previously, we had an enum called gl_shader_type which represented
> pipeline stages in the order they occur in the pipeline
> (i.e. MESA_SHADER_VERTEX=0, MESA_SHADER_GEOMETRY=1, etc), and several
> inconsistently named functions for converting between it and other
> representations:
> 
> - _mesa_shader_type_to_string: gl_shader_type -> string
> - _mesa_shader_type_to_index: GLenum (GL_*_SHADER) -> gl_shader_type
> - _mesa_program_target_to_index: GLenum (GL_*_PROGRAM) -> gl_shader_type
> - _mesa_shader_enum_to_string: GLenum (GL_*_{SHADER,PROGRAM}) -> string
> 
> This patch tries to clean things up so that we use more consistent
> terminology: the enum is now called gl_shader_stage (to emphasize that
> it is in the order of pipeline stages), and the conversion functions are:
> 
> - _mesa_shader_stage_to_string: gl_shader_stage -> string
> - _mesa_shader_enum_to_shader_stage: GLenum (GL_*_SHADER) -> gl_shader_stage
> - _mesa_program_enum_to_shader_stage: GLenum (GL_*_PROGRAM) -> gl_shader_type

You mean "-> gl_shader_stage" on the line above.

Patch 1 is:
Reviewed-by: Kenneth Graunke <kenneth at whitecape.org>

> - _mesa_progshader_enum_to_string: GLenum (GL_*_{SHADER,PROGRAM}) -> string
> 
> In addition, MESA_SHADER_TYPES has been renamed to MESA_SHADER_STAGES,
> for consistency with the new name for the enum.





More information about the mesa-dev mailing list