[OpenFontLibrary] Broken preview on openfontlibrary.fontly.org

Daniel Johnson il.basso.buffo at gmail.com
Mon Aug 17 11:26:55 PDT 2009

OK, I've tracked down the problem with the @font-face all showing the
Medium.  This occurred both with Firefox and Arora (I don't have
Safari or Chrome installed).  I haven't verified that this problem
exists on any platform other than WinXP; I'll have to give it a try on
my Linux box when I get home tonight.  If the fonts are NOT installed
locally, display is correct; but if they *are* installed locally, only
the Medium Upright shows up.


On Mon, Aug 17, 2009 at 2:09 PM, Ben Weiner<ben at readingtype.org.uk> wrote:
> Hi Daniel,
> Daniel Johnson wrote:
>> I uploaded my Pfennig font to the new OFL site just to test the
>> interface out, and I noticed that the PNG-preview for the Bold Italic
>> did not pick up any of the glyphs:
>> http://openfontlibrary.fontly.org/files/Daniel_J/72
>> Re-uploading the .otf file did not change this.  I've verified in
>> FontForge that the .otf is not corrupt.
> :-(
>> Also, in IE the four weight/style combinations show up correctly under
>> "Font Linking with @font-face",
> You've got them installed locally - right now we don't serve up EOT versions
> to IE and it cannot download and display linked fonts in OTF format :-/
> Uninstall them and you will see that there's a monospace font instead.
>>  but in Firefox 3.5.2 Medium Upright
>> shows up for all four.
> Hmm. I'm seeing what looks like the right fonts on Safari 4/Mac - what do
> you see with that browser or with Chrome?
> Cheers,
> Ben
> --
> Ben Weiner | http://readingtype.org.uk/about/contact.html

More information about the OpenFontLibrary mailing list