bugzilla entries for the X11R6.7 release
torrey at mrcla.com
Mon Mar 29 23:26:07 PST 2004
At 11:53 PM -0500 3/29/04, Harold L Hunt II wrote:
>Jim Gettys wrote:
>>I spent a lot of time this afternoon working on the components.
>>Please take a look at what is there now and let me know what you
>>think should change.
>I still think that "server" is too generic and that in this area the
>user should specify at least what ddx they are running since a
>problem in darwin proper is of no concern to people working on other
>I think that "Server/general", "Server/cygwin", "Server/darwin",
>etc. would be a good start. If a user files something in
>"Server/cygwin" that I determine to be generic to all ddxs (e.g. os,
>dix, or Xext bug) then I can just refile it to "Server/general"; the
>same goes for if a user files a bug against any other ddx, just
>change the component if it sounds generic.
>What do you think?
Since it is easy to change the component, I don't have a strong
opinion. I'd lean towards having a generic server component with
possible ddx components as well (DDX/Darwin, DDX/Cygwin, DDX/Xorg).
It is true that on Darwin/Mac OS X you are going to be using a
different ddx, but the majority of the X server code is common. The
average bug reporter will have no idea where the problem lies so the
question is whether you want to assume it is general or specific to
ddx by default. I think it is better practice to assume it is
general, have the most number of eyeballs looking at it, and then
specialize down from there. Different people have different expertise
in solving problems in various areas of the X server. If given a
choice between "server" and "DDX/Darwin", the uninformed user will
generally choose server, which is what we want I think.
In practice many bugs discovered and reported in XDarwin have been
traced back to bugs in common code. Of course, there have been many
XDarwin specific bugs as well. All the same, it is best practice to
go from the most general to the specific rather than assuming certain
edge cases are specific by default.
P.S. Any reason why "Drivers/ATI Mach" is the only plural "Drivers"
component and the rest are singular?
More information about the release-wranglers