[avahi] No libavahi-qt3.so.0 found

Michael Stelluti michael_lba at hotmail.com
Fri Aug 18 10:08:30 PDT 2006

Since I compiled Amarok from source, I proceeded with a recompile to see if 
that would solve my problem.  Well it didn't.  I still get the same error.

Two questions:
1) Do I have to add something to the ./configure command to strictly tell it 
to use libavahi-qt3-1 ?

2) if not, where can I find the debian package for libavahi-qt3-0?  It 
doesn't show up using apt-cache search libavahi-qt.

>From: Simon McVittie <smcv-2005-avahi at pseudorandom.co.uk>
>Reply-To: Avahi ML <avahi at lists.freedesktop.org>
>To: Avahi ML <avahi at lists.freedesktop.org>
>Subject: Re: [avahi] No libavahi-qt3.so.0 found
>Date: Thu, 17 Aug 2006 18:31:14 +0100
>On Thu, 17 Aug 2006 at 13:17:48 +0000, Michael Stelluti wrote:
> > KLibLoader could not load the plugin:
> > libamarok_daap-mediadevice
> > Error message:
> > libavahi-qt3.so.0: cannot open shared object file: No such file or 
> >
> > I have installed libavahi-qt3-1 and libavahi-qt3-dev  but I still don't 
> > a libavahi-qt3.so.0 file.
>In Debian (and derived distros, e.g. Ubuntu), libavahi-qt3.so.0 would be in 
>package called libavahi-qt3-0. You need to either install libavahi-qt3-0
>(which would be part of an older version of Avahi - you should be able
>to have both the -0 and -1 versions installed at the same time), or 
>amarok against the newer version of avahi you now have.
>If you installed Amarok from a Debian package, this is a bug in that
>package - it should have a dependency on libavahi-qt3-0, so please report
>this to whoever supplied you with that package.
>If you installed Amarok from source yourself, just recompile it - now that
>you have the newer libavahi-qt3-dev installed, this should produce a binary
>which links against .so.1 instead.
>Hope this helps,
>	Simon
>avahi mailing list
>avahi at lists.freedesktop.org

More information about the avahi mailing list