[avahi] Service discovery not working...

snott skye at f4.ca
Mon Aug 25 15:27:46 PDT 2008

Hello avahi-users,

I installed avahi on my FreeBSD box (without X11 etc tools, Python bindings
only) and by default it publishes a _ssh._tcp service.  Using avahi-0.6.23
from ports

When I run the PythonBrowseExample script from here, modified to find


(tokyo-cc2 is localhost on

# ./browse-ssh
Found service 'tokyo-cc2' type '_ssh._tcp' domain 'local' 
service resolved
name: tokyo-cc2
port: 22

Likewise on the "other" box on - finds itself but not the other

# ./avahi-browse-example 
Found service 'tokyo-cc3' type '_ssh._tcp' domain 'local' 
service resolved
name: tokyo-cc3
port: 22

I've verified mDNS packets are being passed around, although I'm not well
versed in the protocol:

# tcpdump ip multicast | grep 
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on em0, link-type EN10MB (Ethernet), capture size 96 bytes
22:17:55.487757 IP > 0*- [0q] 14/0/0
(Cache flush) A,[|domain]
22:18:07.913571 IP > 0 [2q] [3n] ANY (QM)?[|domain]
22:18:08.164487 IP > 0 [2q] [3n] ANY (QM)?[|domain]
22:18:08.415450 IP > 0 [2q] [3n] ANY (QM)?[|domain]
22:18:08.615979 IP > 0*- [0q] 3/0/0 (Cache
flush) PTR[|domain]
22:18:08.747514 IP > 0 [3q] [6n][|domain]
22:18:08.998507 IP > 0 [3q] [6n][|domain]
22:18:09.249530 IP > 0 [3q] [6n][|domain]
22:18:09.449915 IP > 0*- [0q]
22:18:09.696613 IP > 0*- [0q] 2/0/0 (Cache
flush) PTR[|domain]
22:18:10.531213 IP > 0*- [0q]
22:18:11.777882 IP > 0*- [0q] 3/0/0 (Cache
flush) PTR[|domain]
22:18:12.612167 IP > 0*- [0q]

I also tried the pybonjour python browser with libdns bindings with the same
As you can see, it is finding an iphone on the network somewhere fine, so I
don't think its the switch :)

# python browse_and_resolve.py _ssh._tcp 
Service added; resolving
Resolved service:
  fullname   = tokyo-cc2._ssh._tcp.local.
  hosttarget = tokyo-cc2.local.
  port       = 22

Service added; resolving
Resolved service:
  fullname   = Vonny\032Juliana\226\128\153s\032iPhone._ssh._tcp.local.
  hosttarget = Macintosh-001B63EAFEBB.local.
  port       = 22
Service removed

Any suggestions??? 

Thank you,

View this message in context: http://www.nabble.com/Service-discovery-not-working...-tp19152852p19152852.html
Sent from the Free Desktop - avahi mailing list archive at Nabble.com.

More information about the avahi mailing list