[avahi] Record too large, cannot send

JOna Brax jblistat at sll.fi
Wed Nov 7 08:50:44 PST 2012


I found this same bug when I tried to add my 21st TimeMacine-client to 
Ubuntu-12.04 netatalk afp fileserver.

I scanned the avahi-mailarchive from 2011 to this day and the last time 
this problem was mentioned seemed to be on Mon Oct 3 2011.

I would like to add ten more TimeMachine-clients, so any information 
about a fix or a workaround to this problem would be highly appreciated.


>> From: avahi-bounces+edward.harvey=analog.com at lists.freedesktop.org
>> [mailto:avahi-bounces+edward.harvey=analog.com at lists.freedesktop.org]
>> On Behalf Of Harvey, Edward
>> I tracked this down through the source code, and found the AvahiDnsPacket
>> has a property called max_size, which gets set based on the system mtu.  So I
>> changed the system mtu (tried increasing from 1500 to 1600) and restarting
>> avahi-daemon and netatalk...
>> The log message disappeared (No more avahi-daemon "Record too large,
>> cannot send" appearing in the syslog) but the client still cannot see the
>> server with 21 shares or more.  (Again, yes can browse afp:// but no, does
>> not populate list via bonjour)
>> So I'm hoping someone might have some more useful information or
>> suggestions...
> Would anybody else care to reproduce this bug?  It's surprising to me that I'm the first person in the multiverse trying to use more than 20 time machine clients on a single backup server...
> Based on what I've experienced, I'm going to draw the conclusion that it is indeed a bug.  Even if I'm not going to work on it myself, I'd like to make sure it's reported to the proper authorities.  Is this mailing list the best place?  Is there a bug tracker somewhere?
> Thanks...

More information about the avahi mailing list