[cairo] Updated ROADMAP for cairo 1.2.0 (and beyond)

Dominic Lachowicz domlachowicz at gmail.com
Thu Apr 27 06:38:55 PDT 2006


> So I'd like to move this functionality to a function separate from
> create. Maybe:
>
>         void
>         cairo_svg_surface_set_version (cairo_svg_version_t version);

I was thinking that it might be preferable to do something like the
following. It would give us a constructor with a default behavior as
well as avoid the timing-specific set_vesion() function. What do you
think?

/* picks one of the two functions below, probably the 1.1 version */
cairo_svg_surface_create (void);

/* creates a SVG 1.1 compatible surface */
cairo_svg_surface_create_1_1 (void);

/* ... */
cairo_svg_surface_create_1_2 (void);

Best,
Dom
--
Counting bodies like sheep to the rhythm of the war drums.


More information about the cairo mailing list