[cairo] Updated ROADMAP for cairo 1.2.0 (and beyond)
taraben.a at wige-data.de
Thu Apr 27 07:50:47 PDT 2006
Carl Worth schrieb:
> On Thu, 27 Apr 2006 09:38:55 -0400, "Dominic Lachowicz" wrote:
>> I was thinking that it might be preferable to do something like the
>> /* creates a SVG 1.1 compatible surface */
>> cairo_svg_surface_create_1_1 (void);
>> /* ... */
>> cairo_svg_surface_create_1_2 (void);
> The underscore is a bit ugly, but I suppose we'd have the same problem
> with an enum, (and I'm not interested in a string here).
> So I guess I'm in favor of this. What do you think, Emmanuel?
So this means every new version you change the API?
I would prefer this:
cairo_svg_surface_create_1_2 (int major_version, int minor_version)
If you would really prevent enums or strings.
More information about the cairo