[cairo] Updated ROADMAP for cairo 1.2.0 (and beyond)
emmanuel.pacaud at univ-poitiers.fr
Thu Apr 27 07:04:28 PDT 2006
Le jeudi 27 avril 2006 à 06:50 -0700, Carl Worth a écrit :
> On Thu, 27 Apr 2006 09:38:55 -0400, "Dominic Lachowicz" wrote:
> > I was thinking that it might be preferable to do something like the
> > following. It would give us a constructor with a default behavior as
> > well as avoid the timing-specific set_vesion() function. What do you
> > think?
> Yes, this looks like it has some good properties. It's also allows for
> us to extend existing _create functions similarly in the future
> (perhaps cairo_ps_surface_create_language_level_3).
> And it does follow the general cairo tendency of pushing values into
> function names rather than adding extra arguments.
> > /* picks one of the two functions below, probably the 1.1 version */
> > cairo_svg_surface_create (void);
> Presumably that's a comment for our sake now, and not the way we'll
> document this function. ;-)
> > /* creates a SVG 1.1 compatible surface */
> > cairo_svg_surface_create_1_1 (void);
> > /* ... */
> > cairo_svg_surface_create_1_2 (void);
> The underscore is a bit ugly, but I suppose we'd have the same problem
> with an enum, (and I'm not interested in a string here).
> So I guess I'm in favor of this. What do you think, Emmanuel?
It's ok for me.
More information about the cairo