[cairo] pangocairo misbehaves on Mac OS X 10.5 (using Quartz/ATSUI, no Xlibs)

Alex Shulgin alexander.shulgin at yessoftware.com
Wed Dec 23 03:31:39 PST 2009

Andrea Canciani wrote:
> On Fri, Dec 18, 2009 at 3:13 PM, Alex Shulgin
> <alexander.shulgin at yessoftware.com> wrote:
>> Alex Shulgin wrote:
>>> Andrea Canciani wrote:
>>>> On Fri, Dec 11, 2009 at 3:32 PM, Alex Shulgin
>>>> <alexander.shulgin at yessoftware.com> wrote:
>>>>> Please let me know how can I help in debugging this further.
>>>> Would it be possible for you to test your program on cairo 1.9.4?
>>>> I can reproduce the bugs I linked above on 1.8.8 but they are not
>>>> present in 1.9.4
>>> OK, I've tried it with 1.9.4 and it crashed in exactly the same manner
>>> (only line numbers in the backtrace are different).
>>> I've also tried recompiling pixman, cairo-1.9.4 and pango with CFLAGS=-O0
>>> and the results are the same.
>>> What do I do?  Should I try different version of gcc?
>> Hey, BUMP again!
>> I've checked there's like a dozen gcc versions on MacPorts:
>> http://www.macports.org/ports.php?by=name&substr=gcc
>> Which do I pick?  Is it worth to try?
> Sorry for the delay, I had to install glib and pango.
> I managed to reproduce the problem, but I still have to investigate it.


any progress on this?

I'm trying ATSU text layout functions bound to a CGContext as a possible 
workaround now, but it seems not working out.

Anyway, thanks for your effort!

More information about the cairo mailing list