[cairo] pangocairo misbehaves on Mac OS X 10.5 (using Quartz/ATSUI, no Xlibs)

Andrea Canciani ranma42 at gmail.com
Wed Dec 23 07:52:35 PST 2009

On Wed, Dec 23, 2009 at 12:31 PM, Alex Shulgin
<alexander.shulgin at yessoftware.com> wrote:
> Andrea Canciani wrote:
>> On Fri, Dec 18, 2009 at 3:13 PM, Alex Shulgin
>> <alexander.shulgin at yessoftware.com> wrote:
>>> Alex Shulgin wrote:
>>>> Andrea Canciani wrote:
>>>>> On Fri, Dec 11, 2009 at 3:32 PM, Alex Shulgin
>>>>> <alexander.shulgin at yessoftware.com> wrote:
>>>>>> Please let me know how can I help in debugging this further.
>>>>> Would it be possible for you to test your program on cairo 1.9.4?
>>>>> I can reproduce the bugs I linked above on 1.8.8 but they are not
>>>>> present in 1.9.4
>>>> OK, I've tried it with 1.9.4 and it crashed in exactly the same manner
>>>> (only line numbers in the backtrace are different).
>>>> I've also tried recompiling pixman, cairo-1.9.4 and pango with
>>>> CFLAGS=-O0
>>>> and the results are the same.
>>>> What do I do?  Should I try different version of gcc?
>>> Hey, BUMP again!
>>> I've checked there's like a dozen gcc versions on MacPorts:
>>> http://www.macports.org/ports.php?by=name&substr=gcc
>>> Which do I pick?  Is it worth to try?
>> Sorry for the delay, I had to install glib and pango.
>> I managed to reproduce the problem, but I still have to investigate it.
> Hi,
> any progress on this?
Basically the assertion is caused by an invalid assumption in cairo code.
I have identified this problem, I don't have a fix ready, but I hope
to find one soon (probably I'll need help from ickle and/or behdad).
The incorrect rendering is a somewhat known bug, as the quartz font
backend doesn't really (fully? correctly?) support the whole unicode,
since it's based on CoreFont. To fix this problem a new font backend
based on CoreText would be needed (and maybe fallback to ATSUI for
backward compatibility), but this would be quite a big change.
Andrea Canciani

More information about the cairo mailing list