[cairo] Question on Cairo installation error

suzuki toshiya mpsuzuki at hiroshima-u.ac.jp
Fri Aug 3 00:54:44 PDT 2012

I guess modern Linux distributions have a package management systems
like apt (Debian, Ubuntu), yum (RedHat, Fedora) or yast (Suse) that
can track the inter-package dependency and install the required package
automatically. Please check the manuals of the distribution that you're

However, most of modern Linux distributions might already distribute
the precompiled cairo packages, so you're not required to build cairo
by yourself (if you're not trying a combination of legacy dependent
libraries + latest cairo, or latest dependent libraries + legacy cairo).


Nurman S wrote:
> Thanks, Suzuki.
> Can someone please get me up to speed on the installation?
> I tried to install xrender library (libXrender-0.9.7). I couldn't because
> it asked me to install renderproto (renderproto-0.11.1).
> Now when trying to install renderproto, it asked me for xorg-macross, which
> I'm unsure which package to donwload.
> Do I just need to install the whole X11? Can I do this on Linux VPS?
> Thanks in advance for your help.
> On Thu, Aug 2, 2012 at 7:48 PM, suzuki toshiya
> <mpsuzuki at hiroshima-u.ac.jp>wrote:
>> I guess you've not installed Xrender library.
>> Nurman S wrote:
>>> Hello all,
>>> First time joining the mailing list. Have a problem with the cairo
>>> installation and would like to seek some advice.
>>> This is for linux platform.
>>> I installed pixman (0.26.0) without problem.
>>> I also ran command 'export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig'. It
>>> seemed to fix the error on not being able to locate pixman during cairo's
>>> ./configure phase.
>>> For the cairo installation (latest version - 1.12.2), I ran ./configure
>>> then make. I got the following error:
>>> cairo-xlib-source.c: In function 'color_source':
>>> cairo-xlib-source.c:424: error: implicit declaration of function
>>> 'XRenderCreateSolidFill'
>>> cairo-xlib-source.c:424: warning: nested extern declaration of
>>> 'XRenderCreateSolidFill'
>>> make[3]: *** [cairo-xlib-source.lo] Error 1
>>> What is the cause of the above error? Do I need to install any other
>>> packages prior?
>>> Thank you in advance for your help.
>>> Nurm

More information about the cairo mailing list