[cairo] possible regression with cario 1.12.10-1

phani listmail at phanisvara.com
Mon Jan 21 20:01:20 PST 2013

after upgrading cairo 1.12.8-2 -> 1.12.10-1 from archlinux [extra], i  
found that zooming of images in GIMP (2.8.2 stable as well as 2.9 GIT  
master) didn't work properly anymore:

as soon as the image gets larger than the size GIMP displays on opening  
the file (fit into window), the image breaks up into apparently random,  
rectangular tiles. panning the image so that parts of it leave the screen  
restores those parts.

also, using tools like scissors or path, leaves artefacts on the image  
that can be removed the same way, i.e., swivelling / panning the image  
across all screen borders.

i've tried various things, like downgrading kernel & video drivers, to no  
avail. finally it was suggested on the arch users' mailing list to  
downgrade cairo, which solved the problem.

here's my system info, in case that helps:

System:    Host: laptop Kernel: 3.7.3-1-ARCH x86_64 (64 bit) Desktop: KDE  
4.9.98 Distro: Arch Linux
Machine:   Mobo: ASUSTeK model: K53SK version: 1.0 Bios: American  
Megatrends version: K53SK.203 date: 10/11/2011
CPU:       Quad core Intel Core i7-2670QM CPU (-HT-MCP-) clocked at 800.00  
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated  
Graphics Controller
            Card-2: Advanced Micro Devices [AMD] nee ATI Whistler LE [AMD  
Radeon HD 6625M Graphics]
            X.org: 1.13.1 drivers: ati,radeon,intel Resolution: 147x57


More information about the cairo mailing list