User authentication to services
kay.sievers at vrfy.org
Fri Jun 18 08:00:27 PDT 2004
On Fri, 2004-06-18 at 16:25 +0200, Olivier Andrieu wrote:
> Kay Sievers [Fri, 18 Jun 2004]:
> > > - the BaseName property replicates the functionality of
> > > the GetServiceOwner, so we need to decide between these two.
> > I've replaced it by GetProperty and changed:
> > dbus/glib/dbus-gproxy.c:dbus_gproxy_new_for_service_owner() to call
> > it instead. (Hmm, needs to be tested if it still works)
> > Is it ok, this way? If yes, I will change the spec too.
> What's wrong with having two different methods ? With a single
> GetProperty method the reply message carries either an INT32 or a
> STRING. That(s not very nice.
I don't have a problem with the "dynamic type", but keeping them as
separate methods may be cleaner. We can also keep the 'service' and
'connection' naming by not merging them.
> > > - the name "GetServiceProperty" isn't a bit funny; it's a
> > > property of the connection, not the service.
> > > Suggest just "GetProperty"
> But the base name is a property of the service.
Hmm, we have too many options now:
1. just add another method to get the uid
(easy to to, doesn't touch existing code)
2. merge into a generic method
(with dynamic return type)
3. merge into a string list returning method
(just one call for n properties, but heavy interface and uid is
converted to a string)
No strong feeling, I'm fine with any of the options.
I just don't like the uid to be a string :)
Which way to take, please share your thoughts?
More information about the dbus