walters at verbum.org
Fri Feb 25 12:15:02 PST 2005
On Wed, 2005-02-23 at 23:45 -0500, Havoc Pennington wrote:
>On Wed, 2005-02-23 at 23:20 -0500, Colin Walters wrote:
>> >I would just move/rename _dbus_type_is_basic() to dbus_type_is_basic()
>> >probably, along with the related functions. Maybe type_to_string (rename
>> >to "type to long"?), type_is_container, type_is_fixed_length.
>> I just moved type_is_basic and type_is_container; I'm not sure I see
>> where/how type_to_string and type_is_fixed_length would be used outside
>> of dbus.
>There are cut-and-pastes in dbus-gutils.c and dbus-tree-view.c for
>type_to_string. Somewhat orthogonal to this patch though if you want to
>skip it for now.
These are gone now actually in my later glib patch; I think we should
either generalize to the human-readable signature stuff, or eliminate.
>Purpose of is_fixed_length would be to automate use of
>iter_get_fixed_array(), but we should probably keep it private until we
>write code that automates that since we could also need e.g.
>get_alignment to write that code. We will need this code in dbus-glib
>eventually because it's prohibitively slow to iterate through arrays
>item-by-item. (Think of images as byte array, with the whole
>DBusTypeReader machinery for every byte)
Ah, that makes sense.
>Some asserts in dbus-signature.c should be return_if_fail (for bad args
>passed to a public function)
>No other showstoppers here.
Committed now, thanks.
>The only further change I'd consider
>important is more exhaustive test coverage as for dbus-marshal-recursive
>but we can mop that up later if you want to commit this first.
This makes sense; I'll have a look at merging the tests soon.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.freedesktop.org/archives/dbus/attachments/20050225/52296e08/attachment.pgp
More information about the dbus