hp at redhat.com
Fri Feb 25 18:21:10 PST 2005
On Fri, 2005-02-25 at 15:15 -0500, Colin Walters wrote:
> On Wed, 2005-02-23 at 23:45 -0500, Havoc Pennington wrote:
> >On Wed, 2005-02-23 at 23:20 -0500, Colin Walters wrote:
> >> >I would just move/rename _dbus_type_is_basic() to dbus_type_is_basic()
> >> >probably, along with the related functions. Maybe type_to_string (rename
> >> >to "type to long"?), type_is_container, type_is_fixed_length.
> >> I just moved type_is_basic and type_is_container; I'm not sure I see
> >> where/how type_to_string and type_is_fixed_length would be used outside
> >> of dbus.
> >There are cut-and-pastes in dbus-gutils.c and dbus-tree-view.c for
> >type_to_string. Somewhat orthogonal to this patch though if you want to
> >skip it for now.
> These are gone now actually in my later glib patch; I think we should
> either generalize to the human-readable signature stuff, or eliminate.
Yeah, I forgot about that problem. The only legit use of the existing
type_to_string() is debug spew to print a type _code_ where no signature
is allowed; there are such uses inside libdbus but probably not outside.
More information about the dbus