[patch][python] Deprecate all arguments called named_service, use bus_name instead

John (J5) Palmieri johnp at redhat.com
Thu May 3 08:21:16 PDT 2007

On Thu, 2007-05-03 at 13:26 +0100, Simon McVittie wrote:
> 'named_service' is a misleading name for a parameter - what we actually
> mean is bus name. It may be a well-known name ("service name"), or not.

Actually a bus name is a well known name.  It doesn't include unique
names.  For the union of the two the term is just 'name'. So 'dbus_name'
like dbus_interface?.

> This patch also deprecates the 'bus' argument to ProxyObject, renaming
> it to 'conn', because any connection will do.

Other than that it looks good.

John (J5) Palmieri <johnp at redhat.com>

More information about the dbus mailing list