[patch][python] Deprecate all arguments called named_service,
use bus_name instead
simon.mcvittie at collabora.co.uk
Thu May 3 09:15:33 PDT 2007
-----BEGIN PGP SIGNED MESSAGE-----
On Thu, 03 May 2007 at 11:21:16 -0400, John (J5) Palmieri wrote:
> On Thu, 2007-05-03 at 13:26 +0100, Simon McVittie wrote:
> > 'named_service' is a misleading name for a parameter - what we actually
> > mean is bus name. It may be a well-known name ("service name"), or not.
> Actually a bus name is a well known name. It doesn't include unique
> names. For the union of the two the term is just 'name'. So 'dbus_name'
> like dbus_interface?.
That's not what the spec says:
Connections have one or more bus names associated with them. A
connection has exactly one bus name that is a unique connection name.
so I stand by my naming. However, if you want me to change this anyway,
now would be the time.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: OpenPGP key: http://www.pseudorandom.co.uk/2003/contact/ or pgp.net
-----END PGP SIGNATURE-----
More information about the dbus