buid failed on win32 and cmake

Julien Isorce julien.isorce at gmail.com
Sun Nov 22 15:28:11 PST 2009


First, thx a lot for helping me.

I have tried the binaries you pointed me.

Unfortunatelly I got the same result:

When I run dbus-daemon in a service (user name is SYSTEM so) ,
then dbus-monitor --system   failed (run as default user: Administrator)

It works well if I run the dbus-daemon as Administrator so it seems that
even using system bus,
it seems that the user name is used to check something ...

I attach the log of the client to this mail.


2009/11/22 Ralf Habacker <ralf.habacker at freenet.de>

> Julien Isorce schrieb:
>  Hi,
>> I got the exact same result with the git repository of dbus4win.
>> I also tried the big patch you submited, but I still got the same error
>> about version macro not defined.
> windbus sources (subdir tags/1.2.4)  are compilable with cmake and contains
> the required patches for initial system bus support (all local users are
> allowed to connect to system bus)
> For your convencience a binary package containing the related patches is
> available from
> http://www.winkde.org/pub/kde/ports/win32/repository/win32libs/dbus-vc90-1.2.4-2-bin.tar.bz2
> Regards
> Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freedesktop.org/archives/dbus/attachments/20091123/1872ca62/attachment.html 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: client.log
Type: application/octet-stream
Size: 18454 bytes
Desc: not available
Url : http://lists.freedesktop.org/archives/dbus/attachments/20091123/1872ca62/attachment-0001.obj 

More information about the dbus mailing list