buid failed on win32 and cmake

Ralf Habacker ralf.habacker at freenet.de
Sun Nov 22 22:45:49 PST 2009

Julien Isorce schrieb:
> Hi,
> First, thx a lot for helping me.
> I have tried the binaries you pointed me.
> Unfortunatelly I got the same result:
> When I run dbus-daemon in a service (user name is SYSTEM so) ,
> then dbus-monitor --system   failed (run as default user: Administrator)
> It works well if I run the dbus-daemon as Administrator so it seems 
> that even using system bus,
> it seems that the user name is used to check something ...
this can be inspected by having the server log  too.

It may be that under the SYSTEM account the directory for the dbus 
keyring is invalid.
Do you have set DBUS_TEST_HOMEDIR for the server *and* the client  ?


> I attach the log of the client to this mail.
> Sincerely
> Julien
> 2009/11/22 Ralf Habacker <ralf.habacker at freenet.de 
> <mailto:ralf.habacker at freenet.de>>
>     Julien Isorce schrieb:
>         Hi,
>         I got the exact same result with the git repository of dbus4win.
>         I also tried the big patch you submited, but I still got the
>         same error about version macro not defined.
>     windbus sources (subdir tags/1.2.4)  are compilable with cmake and
>     contains the required patches for initial system bus support (all
>     local users are allowed to connect to system bus)
>     For your convencience a binary package containing the related
>     patches is available from
>     http://www.winkde.org/pub/kde/ports/win32/repository/win32libs/dbus-vc90-1.2.4-2-bin.tar.bz2
>     Regards
>     Ralf

More information about the dbus mailing list