Need help on setting D-Bus

Sathia Narayanan msathia at
Mon Sep 27 10:28:39 PDT 2010

do you have user "messagebus" or "dbus" user created by launch script. Is
the libdbus correctly available in the configuration file. .

How does your launch script looks like. What is causing segmentation fault?
very little information is actually available from your mail to understand
what is happening

On Mon, Sep 27, 2010 at 10:17 AM, Yedire, Sandeep <syedire at> wrote:

> Hello there,
> I am newbie to D-Bus. I am currently setting up connection for
> Bluetooth Head-set and Target(MIPS ARC).  When I tried sending the
> pass key to headset thru passkey agent, I get error message "Cant get
> on system bus". I googled and found its related to D-Bus.
> I have cross-compiled the dbus-1.2.24, expat, glib libraries and also
> built bluez-4.69.
> During the build of D-Bus I don't see system_bus_socket file being
> created in that directory during the build process.
> After login into target as root, I tried executing below commands
> >export DBUG_VERBOSE=1
> >dbus-daemon --system
> But the dbus-daemon is not started. Instead I get segmentation fault.
> My doubt: How do I start dbus-daemon on target? I understand this
> needs to be running to establish communication between two
> applications.
> How do I start this daemon?
> FYI my kernel version on target 2.6.18.
> Please suggest on this.
> Regards,
> Sandeep.Yedire
> ----------------------------------------------------------
> T.Jefferson, 'Victory and defeat are each of the same price"
> _______________________________________________
> dbus mailing list
> dbus at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the dbus mailing list