dim setup suggestion

Souza, Jose jose.souza at intel.com
Fri Nov 9 21:31:45 UTC 2018

After a clear dim setup, I ran 'dim apply-queued' and got this error:

You're on the wrong branch, expected drm-intel-next-queued in

Checking the remotes added by 'dim setup' and none of then pointed to
git.freedesktop.org/git/drm-intel so I added it by hand and did a
checkout to drm-intel/drm-intel-next-queued to be able proceed with
'dim apply-queued'.

I briefly talked to Rodrigo after push the patches to drm-intel-next-
queued and he told me that I should have run: 'dim conq' after setup
also that dim was written in generic way so it can be used by other drm

So my sugestion is have a 'dim setup <project>' or something similar to
setup dim as easy as possible for drm-intel and other drm projects.

Also when running 'dim push-queued' I got:
fatal: no upstream configured for branch 'drm-intel-next-queued'
fatal: no upstream configured for branch 'drm-intel-next-queued'
So I probably did not properly fixed it by hand yet.

Other think is the maintainer-tools branch from 
https://anongit.freedesktop.org/git/drm/drm-tip.git that I think it
should be removed or kept in sync with 
https://gitlab.freedesktop.org/drm/maintainer-tools.git . I had started
the setup using the the old repository as I alread had fetch it some
time ago but Rodrigo warned me about the new repository.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: This is a digitally signed message part
URL: <https://lists.freedesktop.org/archives/dim-tools/attachments/20181109/77ff4f31/attachment.sig>

More information about the dim-tools mailing list