drm/amdkfd: bad CONFIG_ prefix for enum entries

Valentin Rothberg valentinrothberg at gmail.com
Thu Jun 4 06:59:08 PDT 2015

Hi Oded,

On Thu, Jun 4, 2015 at 3:48 PM, Oded Gabbay <oded.gabbay at gmail.com> wrote:
> Hi Valentin,
> Thanks for catching that.
> I would be grateful if you could fix this yourself.

With pleasure,  I am happy if I can help.  Do you have any preference
to change the prefix to something else?  As there are three other
symbols SH_REG_{BASE,SIZE,END}, I would rename CONFIG_ to CONF_ to
avoid mix-ups.

Kind regards,

> Oded
> On Thu, Jun 4, 2015 at 4:45 PM Valentin Rothberg
> <valentinrothberg at gmail.com> wrote:
>> Hi Yair,
>> your commit fbeb661bfa89 ("drm/amdkfd: Add skeleton H/W debugger
>> module support") has shown up in today's linux-next tree (i.e.,
>> next-20150604).  The commit adds the following lines of code to
>> drivers/gpu/drm/amd/amdkfd/kfd_dbgdev.h:
>> +/* CONFIG reg space definition */
>> +enum {
>> +       CONFIG_REG_BASE = 0x2000,       /* in dwords */
>> +       CONFIG_REG_END = 0x2B00,
>> +};
>> There is a problem with the 'CONFIG_' prefix of those entries.  This
>> prefix is reserved for Kconfig options in Make/Kbuild and CPP syntax,
>> so that static analysis tools (and readers of the code) may mistakenly
>> assume that the symbol is defined somewhere in a Kconfig file.
>> I detected the issue with ./scripts/checkkconfigsymbols.py.  Would you
>> mind renaming those entries to something without the 'CONFIG_' prefix?
>>  I can also take care of it if you wish to.
>> Kind regards,
>>  Valentin

More information about the dri-devel mailing list