drm/amdkfd: bad CONFIG_ prefix for enum entries
valentinrothberg at gmail.com
Thu Jun 4 06:44:43 PDT 2015
your commit fbeb661bfa89 ("drm/amdkfd: Add skeleton H/W debugger
module support") has shown up in today's linux-next tree (i.e.,
next-20150604). The commit adds the following lines of code to
+/* CONFIG reg space definition */
+ CONFIG_REG_BASE = 0x2000, /* in dwords */
+ CONFIG_REG_END = 0x2B00,
+ CONFIG_REG_SIZE = CONFIG_REG_END - CONFIG_REG_BASE
There is a problem with the 'CONFIG_' prefix of those entries. This
prefix is reserved for Kconfig options in Make/Kbuild and CPP syntax,
so that static analysis tools (and readers of the code) may mistakenly
assume that the symbol is defined somewhere in a Kconfig file.
I detected the issue with ./scripts/checkkconfigsymbols.py. Would you
mind renaming those entries to something without the 'CONFIG_' prefix?
I can also take care of it if you wish to.
More information about the dri-devel