[PATCH] accel/habanalabs: use kcalloc() instead of kzalloc()
Gustavo A. R. Silva
gustavo at embeddedor.com
Mon Jan 22 16:45:52 UTC 2024
On 1/20/24 09:10, Erick Archer wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, use the purpose specific kcalloc() function instead of the argument
> size * count in the kzalloc() function.
>
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/162
>
> Signed-off-by: Erick Archer <erick.archer at gmx.com>
Reviewed-by: Gustavo A. R. Silva <gustavoars at kernel.org>
Thanks!
--
Gustavo
> ---
> drivers/accel/habanalabs/common/mmu/mmu_v1.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/accel/habanalabs/common/mmu/mmu_v1.c b/drivers/accel/habanalabs/common/mmu/mmu_v1.c
> index d925dc4dd097..e3d42cfead27 100644
> --- a/drivers/accel/habanalabs/common/mmu/mmu_v1.c
> +++ b/drivers/accel/habanalabs/common/mmu/mmu_v1.c
> @@ -232,7 +232,7 @@ static int dram_default_mapping_init(struct hl_ctx *ctx)
> /* add hop1 and hop2 */
> total_hops = num_of_hop3 + 2;
>
> - ctx->dram_default_hops = kzalloc(HL_PTE_SIZE * total_hops, GFP_KERNEL);
> + ctx->dram_default_hops = kcalloc(total_hops, HL_PTE_SIZE, GFP_KERNEL);
> if (!ctx->dram_default_hops)
> return -ENOMEM;
>
> --
> 2.25.1
>
>
More information about the dri-devel
mailing list