[Fontconfig] RE: Problems going from RH8 to RH9 (probably solution)

Rich Drewes drewes at interstice.com
Thu Apr 17 03:22:14 EST 2003

I experienced the same problem Johnathan Smith reported:  After doing an
upgrade from RH 8.0 to RH 9.0, X refused to start with an error message
like this:

"No fonts found; this probably means that the fontconfig library is not
correctly configured."

I tried clearing away the font cache files and re-running fc-cache -f as
some suggested on this list, but nothing worked.  Since fontconfig was new
for me I didn't know where to start debugging with strace or anything like
that, and the error message above was *not* helpful--in fact it appears to
be wrong, as fc-cache -v showed that lots of fonts were being found.  As
the icing on the cake, "man fontconfig" returned "iconv: illegal input
sequence at position 205".  (That one might be RH's fault.)
 Typical upgrade FUBAR scenario.  Where's the love, Linux?

Following up a lead from another list, I examined the permissions on the
files in all the directories listed in /etc/fonts/fonts.conf.  To my
surprise, some of the font dirs were not world or group readable.  Nor
were these files owned by any RPM package.  It's not clear what package
put them in there, but when I removed them X started working again.  Joy!

Owen Taylor's suggestion to verify the installed fonts was sound, but it
may not be a problem with the font itself but rather just its permissions.

Johnathan Smith:  I tried to CC: you on this message directly, but I could
not find your email address in the list archives.


More information about the Fontconfig mailing list