[Fontconfig] FT_Get_Next_Char error on RH9

Seb James seb at hypercubesystems.co.uk
Thu Nov 20 03:47:08 EST 2003

On Wed, 19 Nov 2003, Seb James wrote:

> Hello,
> I'm getting a curious error from the fontconfig that's installed on my RH9 
> box (fully updated right now).
> A previous posting to this list was similar, and was getting errors like 
> this one:
> gnome-terminal: relocation error: /usr/lib/libfontconfig.so.1: undefined 
> symbol: FT_Get_Next_Char
> Keith Packard had this to say on the subject:
> >Around 9 o'clock on Mar 28, "Maisenhelder, Joel" wrote:
> >> And thus upgraded fonconfig to 2.1. All I get now are  fc-cache: 
> relocation
> >> error: /usr/local/lib/libfontconfig.so.1: undefined symbol:
> >> FT_Get_Next_Char
> >That means the version of FreeType you have installed is not the same as
> >the version used to build fontconfig.
> >> Or if I remove the dirs it has trouble with I get. No fonts found. What 
> is
> >> going on?
> >That's a known bug with version 2.1 of fontconfig which is fixed by
> >running 'fc-cache -f'.  That should be fixed in 2.1.92, but you'll have 
> to
> >fix your FreeType version before you can run that.
> >-keith
> Now, I'm getting the same messages with the freetype and fontconfig that 
> are installed with my distro, nothing is out of place and I've verified 
> that the packages are `as installed'.

It's worth noting that I've scanned through libfreetype.so and the symbol 
FT_Get_Next_Char is defined in there, so the code _is_ on the system.

> The only thing that is different from a normal RH9 distro is that I have a 
> few extra fonts installed in /usr/X11R6/lib/X11/fonts/local.
> I tried recompiling fontconfig (from the RH source rpm) on the system, but 
> the recompiled fontconfig libraries gave the same errors.
> fontconfig version is 2.1-9 (redhat) though I'm not exactly sure which 
> version this translates to.
> Typically, I'm not quite sure at which point the error made itself 
> apparent. It wasn't when I installed ltsp on the machine recently. It 
> mainly seems to have occurred since I tried running type1inst in 
> directories that contained some new fonts, but I think it may have been 
> waiting inthe wings as I don't see how that can have done anything to 
> upset the system.
> Any ideas? This is causing us some trouble as it's our main office 
> server.
> regards,
> Seb James
> _______________________________________________
> Fontconfig mailing list
> Fontconfig at fontconfig.org
> http://fontconfig.org/mailman/listinfo/fontconfig

64 South View Road, Sheffield S7 1DD. tel: 0114 281 4114

More information about the Fontconfig mailing list