[Fontconfig] Fontconfig error: Cannot load default config file

Philippe A z77y16 at hotmail.com
Mon Sep 8 00:55:18 EST 2003


I'm having some issues building fontconfig-2.2.0.

The first problem I've encountered is the doc not building correctly. Maybe 
it's because my version of docbook isn't up to date? I've disabled doc and 
the compile went without errors. Anyways. That's the least of my concerns.

The problem that really concerns me is that whenever I run fc-cache (for 
example), I get the following error message:

Fontconfig error: Cannot load default config file

I tried to trace this error in the code and eventually found that 
FcConfigFilename always returns null for me. Looks like fontconfig does not 
look automatically in /etc/fonts, which is where I have my fresh config 
files installed.

I can work around this problem by defining the FONTCONFIG_FILE env var or by 
overriding the related #define, but I'd rather like to know what is The Way 
of having fontconfig look at the right place.

I tried various configure option but none of them had the expected effect 
(--sysconfdir=DIR and --with-confdir=DIR). I mean, my config files installed 
in the specified dir but fontconfig couldn't find them.

This error is causing various problems. For example, MozillaFirebird won't 
start and my fonts look totally screwed up in kde.

Thanks in advance for any pointers!


MSN Messenger : discutez en direct avec vos amis !  

More information about the Fontconfig mailing list