[Fontconfig] blacklisting doesn't work

Matthias Clasen mclasen at redhat.com
Fri Oct 21 05:40:41 EST 2005

So, I tried to figure out why my fc-list output includes the Hershey
fonts, even though 40-blacklist-fonts.conf is included and read. 
First I figured out that the glob patterns in
the /etc/fonts/conf.d/40-blacklist-fonts.conf file we ship don't have
any effect, since fontconfig does not actually apply globs
to individual fonts. The globs in <rejectfont> are only applied to
directories, and the patterns in <rejectfont> are what is applied to
the individual fonts. So I tried to change the blacklist to a series 
of patterns like

        <patelt name="family">

And the Hershey fonts were still there. It took me quite a while
to figure out that I need to strip the escapes out of the fc-list 
output to give the patterns a chance to work. Is that escaping 
really necessary ? It is certainly confusing...

Anyway, after stripping the escapes out of the patterns, the
Hershey fonts still would not vanish. I finally came to the 
conclusion that something like the patch below will be necessary
to make blacklisting work again.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: blacklisting.patch
Type: text/x-patch
Size: 2452 bytes
Desc: not available
Url : http://lists.freedesktop.org/archives/fontconfig/attachments/20051020/3190e1ab/blacklisting.bin

More information about the Fontconfig mailing list