[Fontconfig] mmap branch vs gnome-terminal

Matthias Clasen mclasen at redhat.com
Tue Sep 13 00:55:56 EST 2005

On Sun, 2005-09-11 at 08:46 -0400, Patrick Lam wrote:
> Matthias Clasen wrote:
> > On Sun, 2005-09-11 at 01:17 -0400, Patrick Lam wrote:
> > 
> >>Matthias Clasen wrote:
> >>
> >>>Here is another problem I met after installing the mmap branch
> >>>fontconfig system-wide on my system. gnome-terminal doesn't
> >>>seem to find fonts anymore. I haven't yet tried to follow all the
> >>>fontconfig pattern manipulation done in vte, but it seems to
> >>>trigger an incompatibility. 
> >>>
> >>>A similar problem seems to affect the previews in the font capplet,
> >>>which also seem to pick up a very small font size. 
> >>
> >>I have fixed this problem.  Let me know if that clears up the problem
> >>for you.  
> > 
> > No, I still see the same problems. gnome-terminal and
> > gnome-font-properties come up with fonts of very small size, and
> > firefox segfaults.
> I'm definitely using the fontconfig branch on this computer with 
> gnome-terminal and firefox, which both work.  (Also thunderbird). 
> However, gnome-font-properties currently doesn't work for me -- it 
> reports no fonts found -- so I'll look into that.  (I thought that my 
> patch got it working last night).

I looked a bit more into my problems, and found that firefox crashes
with an assertion inside pango, if the FONTCONFIG_PATH is set (even if
it is set to the default value /etc/fonts). The assertion I run into is
that a FcPatternGetString (pattern, FC_FAMILY, 0, (FcChar8 **) &s)
returns FcResultTypeMismatch for one pattern. And in fact, if I print 
the pattern, it looks as if the family name is mistaken as a boolean:

Pattern 26 of 32
        family: FcFalse(w)
        familylang: "xx"(s)
        style: "Gothic-Regular"(s)
        stylelang: "xx"(s)
        slant: 0(i)(s)
        weight: 100(i)(s)
        width: 100(i)(s)
        size: 9.75(f)(s)
        pixelsize: 13(f)(s)
        foundry: "unknown"(s)
        antialias: FcTrue(s)
        hintstyle: 2(i)(s)
        hinting: FcFalse(w)
        verticallayout: FcFalse(s)
        autohint: FcFalse(s)
        globaladvance: FcTrue(s)
        index: 0(i)(s)
        outline: FcTrue(s)
        scalable: FcTrue(s)
        rgba: 5(i)(s)
        charset: set(s)
        lang: aa|ast|ay|bg|bi|br|ch|da|de|en|es|eu|fj|fo|fur|fy|gd|gl|
        fontversion: 65536(i)(s)
        capability: "otlayout:kana"(s)
        fontformat: "TrueType"(s)

Starting firefox without a FONTCONFIG_PATH seems to work fine.

Regards,  Matthias

More information about the Fontconfig mailing list