[Fontconfig] Problems installing 2.6.0 on Vista

Sisyphus sisyphus1 at optusnet.com.au
Sat Apr 25 02:29:00 PDT 2009

----- Original Message ----- 
From: "John C. Turnbull" <ozemale at ozemail.com.au>

> The "configure" and "make" commands run perfectly but when I run "make
> install" it crashes

What configure command did you run ?

I've just tried building 2.6.0 on Vista with:

./configure --disable-shared --enable-static CPPFLAGS=-I/usr/local//include 

For me, the 'make install' fails with:
/bin/install: cannot stat `.libs/libfontconfig.dll.a': No such file or 

But that happens after the static lib I successfully built has been 
installed into /usr/local/lib (and the header files installed into 
/usr/local/include), so the error is not of great consequence. (Apparently, 
the belief is that there's also a dynamic build to be installed.)

Once I know what you're configure command was, I'll try to emulate it here 
and see what happens. (Actually, that won't get done until tomorrow night.)

There's a problem with the test suite on Windows, too. The first test 
passes, but the second culminates with:

*** Test failed: Basic check
*** output is in 'out', expected output in 'out.expected'
FAIL: run-test.sh
1 of 1 tests failed

I'm using the source from 
http://fontconfig.org/release/fontconfig-2.6.0.tar.gz , btw.


More information about the Fontconfig mailing list