[Fontconfig] Fontconfig 2.10.0 mingw build broken

Damon Register dregister at clear.net
Sat Jul 21 09:17:29 PDT 2012

I was able to build fontconfig 2.9.0 using mingw without any trouble.  I saw
that 2.10.0 was released so I tried that.  configure seems to complete without
any problem.  When I run make, it seems to want to do config all over again.
make output starts like this:

CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /d/gtki2/fontconfig-2.10.0/missing --run aclocal-1.11
  cd . && /bin/sh /d/gtki2/fontconfig-2.10.0/missing --run automake-1.11 --gnu
CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /d/gtki2/fontconfig-2.10.0/missing --run autoconf
/bin/sh ./config.status --recheck
running CONFIG_SHELL=/bin/sh /bin/sh ./configure --prefix=/c/gtk3 --enable-shared --disable-static CFLAGS=-g LDFLAGS=-L/c/gtk3/l
ib -L/mingw/lib CPPFLAGS=-I/c/gtk3/include -I/mingw/include PKG_CONFIG=/c/gtk3/bin/pkg-config.exe PKG_CONFIG_PATH=/c/MinGW/lib/p
kgconfig:/c/gtk3/lib/pkgconfig --no-create --no-recursion

On this second round of configure, it gives this error

./configure: line 11925: PKG_PROG_PKG_CONFIG: command not found

and then finally fails with:

./configure: line 13010: syntax error near unexpected token `FREETYPE,'
./configure: line 13010: `PKG_CHECK_MODULES(FREETYPE, freetype2)'

I notice that version 2.9.0 also does the repeat configure on running make just
as does version 2.10.0 but unlike 2.10.0, configure completes and make also
completes.  Now I do have pkg-config 0.27, ACLOCAL_FLAGS is defined and pkg.m4 is
in that directory.  Just for fun I also tried starting with
autoreconf --force --install --verbose
but the end result is the same; configure dies.

ACLOCAL_FLAGS=-I /c/gtk3/share/aclocal

make[3]: Entering directory `/d/gtki2/fontconfig-2.10.0/fc-case'
   CC     fc-case.o
   CCLD   fc-case.exe
libtool: Version mismatch error.  This is libtool 2.4.2, but the
libtool: definition of this LT_INIT comes from libtool 2.4.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.2
libtool: and run autoconf again.

I tried without ACLOCAL_FLAGS and just configure (no autoreconf)
I tried without ACLOCAL_FLAGS and autoreconf  then configure.
The result is the same; make results in repeat of configure.
I took a closer look at the output of autoreconf and noticed these

libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac and


libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.

I looked at how those were done in other packages and addeded

   new directory m4



Now autoreconf completes without warning or suggestions.
I was able to do configure, make and make install.  Make does not result in a
repeat configure.  So I guess I solved my own problem (maybe?) but now I am curious why?
Should these things be added to the project?

Damon Register

More information about the Fontconfig mailing list