[Fontconfig] Fontconfig 2.10.0 mingw build broken

Mike Frysinger vapier at gentoo.org
Sat Jul 21 09:41:26 PDT 2012

On Saturday 21 July 2012 12:17:29 Damon Register wrote:
> I was able to build fontconfig 2.9.0 using mingw without any trouble.  I
> saw that 2.10.0 was released so I tried that.  configure seems to complete
> without any problem.  When I run make, it seems to want to do config all
> over again. make output starts like this:
> CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh
> /d/gtki2/fontconfig-2.10.0/missing --run aclocal-1.11

your timestamps are messed up -- autotools should not be automatically 
regenerated.  any errors after this point are irrelevant.

the best way to find out which timestamps are messed up:
rm -rf fontconfig-2.10.0
tar xf fontconfig-2.10.0.tar.bz2
cd fontconfig-2.10.0
./configure <your random flags>
make -d >& log

then look at the log file to see why it thinks it needs to regenerate the 
autotools.  could be your clock is messed up, or you have an old kernel or 
broken filesystem, or something else.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.freedesktop.org/archives/fontconfig/attachments/20120721/d4ccea30/attachment.pgp>

More information about the Fontconfig mailing list