[fprint] uru4000 reader not working correctly with libfprint, please advise

Jules Kerssemakers J.Kerssemakers at cmbi.ru.nl
Thu Apr 26 07:02:53 PDT 2012

Dear libfprint-devvers,

For a forensics practical at our university, we want to obtain fingerprint
images, so the students can simulate the process of feature-detection etc.
on their own fingerprints.
For this purpose, we've obtained two DigitalPersona U.are.U 4000 sensors.

We tried to use these with fprint_demo, but though they are correctly(?)
detected, actual fingerprint detection didn't work.


   1. Start fprint_demo
   2. console prints "** Message: now monitoring fd 10"
   Device is recognised: driver uru4000, imaging device, status: "Device
   ready for use"
   3. After clicking "Enroll" for any finger, a pop-up window appears
   asking "scan your finger now", with a nice progress-bar.
   4. The scan-light on the reader comes on,
   5. BUT touching my finger to the reader doesn't provoke any response.
   Touching for short or long periods of time doesn't change anything.
   6. The Cancel and Quit buttons still respond normally (so main
   event-loop hasn't crashed, apparently)
   7. upon Cancel-ing, the scan-light goes off again.
   8. upon Quit, console prints "** Message: no longer monitoring fd 10"

(no console messages appear in-between)

I also tried the sample programs from the DigitalPersona linux SDK, and
these were able to collect and verify fingerprints from the same reader.
However, the SDK-samples don't spit out the captured ((semi-)raw) image,
which is what we want.

1) What can we do at our end to get the fprint-demo program to scan
fingerprints from our reader?
2) How fares the "image capture" part of fprint_demo (and will it allow
3) Is there any information I can send you to help you diagnose/fix this
problem? (command outputs, traces, etc? when provided with instructions, I
can run USB-sniffers and the like)

Kind regards,
Jules Kerssemakers


   - Reader: DigitalPersona
   "U.are.U 4000 sensor" (non-branded, with DigitalPersona logo on front)
   model# URU-4S-U1
   Part# 50006-001
   Rev. 101
   USBID (lsusb): Bus 004 Device 005: ID 05ba:0007 DigitalPersona, Inc.
   - fprint obtained from ubuntu-fprint PPA:
   libfprint0, version "1:0.4.0+git20110418-0ppa1+debug1~lucid1"
   - OS used:
   Ubuntu 10.04 LTS
   Linux 2.6.32-40-generic #87-Ubuntu SMP Tue Mar 6 00:56:56 UTC 2012
   x86_64 GNU/Linux
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/fprint/attachments/20120426/1470ee1f/attachment.htm>

More information about the fprint mailing list