[fprint] uru4000 reader not working correctly with libfprint, please advise

Jules Kerssemakers J.Kerssemakers at cmbi.ru.nl
Thu Apr 26 15:17:27 PDT 2012

Dear list, an update

(sorry for keeping the previous reply off-list, accidental reply instead of

I have tried compiling the latest versions I could get from
Freedesktop.org: libfprint 0.4.0 and fprintd 0.4.1
I could compile libfprint (configure, make, make install),
but not fprintd (GIO version isn't high enough on ubuntu 10.04, is 2.24.1;
requires >=2.26)

I didn't feel up to screwing my complete OS just to get a higher GIO
version (don't even know what it does..), so I went for the latest versions
I could find in David Jurenka's PPA:
libfprint0     1:0.4.0+git20110418-0ppa1~lucid1
fprintd           0.2.0+git20110125-0ppa1~lucid1

(How up-to-date are those? last compile-time said "two weeks ago", but I
don't know how current the source is, lib-fprint seems OK, fprintd
apparently is "ancient")

With these I tried again, fprintd-enroll, and the device is detected,
scan-light comes on, and nothing happens upon finger-touching to the reader.

I also discovered wireshark also captures USB, so I tried a run:
attached is the capture-file of device insertion to device removal, with a
run of fprint-enroll in-between.
Disclaimer: this is my first time using wireshark or any capture tool, if I
made any mistakes, or you need anything else, let me know.

Timing information:
0.0s - 6.2s --> insert device cable, recognition, (pop-up shows device
recognised as "USB device ZKSoftware Inc. Biokey 200 A&T Sensor")
32.8s - 33.1s --> start fprintd-enroll in console (as normal, non-root,
Try several times touching finger, one time for 15 seconds, hoping for
no new packets appeared what-so-ever
89.5s - 95.3s --> terminate fprintd-enroll with Ctrl+C
108.0s - 111.3s --> unplug device
<<pause, end capture>

I specifically noted that no new packets appeared when I tried touching my
finger to the read-window, neither on finger-on nor finger-hold (waited
15s), nor on finger-off.

So, apart from updating my complete OS to get a higher GIO-version
(allowing me to compile the latest fprintd), what else can I do to get this
thing working?

Kind regards,

On 26 April 2012 17:53, Bastien Nocera <hadess at hadess.net> wrote:

> On Thu, 2012-04-26 at 17:46 +0200, Jules Kerssemakers wrote:
> > Dear Bastien, (CC: david Jurenka)
> >
> > Thanks for the reply!
> Any reason why this discussion isn't kept on the mailing-list?
> <snip>
> > I installed fprintd (version 0.2.0+git20110125-0ppa1~lucid1, by David
> > Jurenka again), and tried the commands you suggested.
> That's ancient. 0.4.1 is the latest release of fprintd. Also make sure
> you have the latest version of libfprint.
> Cheers
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/fprint/attachments/20120427/faf153e0/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: fprintd-enroll_capture_digitalpersona_uru4000
Type: application/octet-stream
Size: 7669 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/fprint/attachments/20120427/faf153e0/attachment.obj>

More information about the fprint mailing list