[fprint] Libfprint on Android

Bastien Nocera hadess at hadess.net
Tue Jan 15 06:06:21 PST 2013

On Tue, 2013-01-15 at 11:57 -0200, Daniel Neis Araujo wrote:
> Ok,
> here is what i did (i am using x86_64 as host):
> * used qemu to boot an ubuntu for arm
> (https://wiki.ubuntu.com/ARM/RootfsFromScratch)
> * build libfprint as on x64_86
> * build the examples
> * started some of them ok
> * copied the examples and the library to my rowboat android jellybean
> 4.1.2 (i can run a prebuilt busybox-armel6 on it)
> * tried to run the examples but received "sh: verify: File not found"

I'm guessing you copied them by hand? Then you just copied the libtool
stubs :)

DESTDIR=/tmp/blah make install
and copy the files from there. Or fish out the library and binaries from
the .libs/ directories.

> * tried add libfprint directory to LD_LIBRARY_PATH but same problem
> maybe i should copy all libfprint dependencies to android too?

You copied libool stubs (shell scripts that are used so that uninstalled
binaries are launched against the uninstalled library).


More information about the fprint mailing list